X-T2 Freezing VF issues

Started 7 months ago | Discussions thread
Flat view
desmo101 Contributing Member • Posts: 810
X-T2 Freezing VF issues

Hey guys,

Have been using my X-T2 since last fall when I purchased it. I had no complaints I love this camera and system. Recently it's been behaving oddly and I can't pinpoint the issue. but it's been happening every time i took the camera out to shoot in the last 2-3 weeks.

Everything will be fine when i start shooting,  then at some point the viewfinder will not activate when i put my eye to the camera, the view mode button becomes unresponsive for a while, the focus joystick is frozen and I can't change the focus points. then a few seconds later it works again, only to fail again later.

I'm using the camera mostly with the grip, lear 1000x pro cards. this happens with all lenses, even manual unconnected lenses with adaptor. I'm using 3rd party batteries NP-w126 not sure if that is relevant.

I'm going to bring it in for service but i thought i'd ask here first just in case I find a solution since it's summer and i hate being without my camera :-(.

thanks, any feedback and ideas would help



 desmo101's gear list:desmo101's gear list
Fujifilm X-T2 Voigtlander 40mm F2 Ultron SL II Fujifilm XF 10-24mm F4 R OIS Fujifilm XF 56mm F1.2 R Fujifilm 16-55mm F2.8R LM WR +2 more
Fujifilm X-T2
If you believe there are incorrect tags, please send us this post using our feedback form.
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow