X-T2 Not Previewing Correctly

Started 3 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Inthishope New Member • Posts: 5
X-T2 Not Previewing Correctly

Ok. I'm stumped. I've searched this and other forums and Google and can't find an answer to this.

When I shoot at night, in pitch black, with high shutter speeds, the preview of my exposure reaches a ceiling where no matter the settings the image preview doesn't get any brighter. I have the Preview in Manual modes set to EXP/WB and the Preview Effect set to ON.

Here is an example:

I set my SS to 20" and my A to 2.8. My ISO is set at 400. The exposure gauge on the side of the LCD and EVF shows that it is metering that the image will be over exposed +2 yet the image is too dark to even compose a shot. If I take the shot, it exposes as I expect, but the preview doesn't show that. If I crank the ISO up to 25600 to make it artificially raise the brightness just so I can compose, it still doesn't get any brighter. The live histogram also does not move when it hits that ceiling. If I lower the ISO to 200 and then start dropping the SS the preview will have a point where the image will start getting darker (to black) but it won't go above that line. 
Is this a setting issue? A design "flaw" (in my opinion...maybe not others). 
I had an a6000, a6300 and a6500 and I remember using them in the dark and being able to crank up the ISO to crank up the preview gain to compose the shot in the dark.

What am I missing?

 Inthishope's gear list:Inthishope's gear list
Fujifilm X-T2 Fujifilm XF 55-200mm F3.5-4.8 R LM OIS Fujifilm XF 27mm F2.8 Samyang 12mm F2 NCS CS Fujifilm 16-50mm F3.5-5.6 II
Fujifilm X-T2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow