Has Olympus Camera Updater destroyed this lens?

Started 3 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Alex Ethridge
Alex Ethridge Senior Member • Posts: 2,225
Has Olympus Camera Updater destroyed this lens?

Olympus OM-D E-M1 and 12-40 2.8 Pro lens.

The battery is at full charge and so is the battery in the grip.  Running Olympus Camera Updater.  The update process recognized the lens and started the update and after a few seconds I got  the sudden and unexpected message it could not detect the camera.

I checked the cables and my computer's internet connection and all appears to be as it should.I waited about five minutes with no change and attempted to turn off the camera and it would not turn off.

End result is now the Camera Updater sees the E-M1 but not the 12-40mm lens.  The updater also sees other lenses, just not the 12-40.  Also, the 12-40 produces no viewable image, totally black EVF and LCD.

Is there a usable fix to try or is it ready for Olympus repair.

If Olympus repair, are there more than one and which one is the best one to use?  Difference in turn around isn't very important as I have other lenses.

 Alex Ethridge's gear list:Alex Ethridge's gear list
Panasonic Lumix DMC-G1 Nikon D800E Olympus E-M1 Olympus E-M5 II Panasonic GH5 +15 more
Olympus E-M1
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
MNE
MNE
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow