a6000 firmware update bricked, no red write light / red write light off, Mac (solved)

Started May 25, 2017 | Discussions thread
ForumParentFirstPrevious
Flat view
WesH
WesH New Member • Posts: 2
a6000 firmware update bricked, no red write light / red write light off, Mac (solved)
2

Hey just throwing this here incase it helps someone, last firmware update did the (seemingly common?) bricking of my a6000 when it failed halfway through. However, the little red read light eventually turned off and would not turn back on, which seemed to be a bit more uncommon. My steps that worked:

1) Fully charge the battery overnight, batter out of camera. (If your write light is on it may turn off overnight)

2) Use a cable other than the micro USB cable that came with the camera and plug into your laptop. ...Not sure if mine broke.

3) Turn the camera on and off repeatedly while plugged in until the red read light comes back on. Think I did this 12-20x.

4) Run updater, voila.

To confirm step 2-3 worked :

I can't really explain step 3 toggling the power, i've never had power button issues so I doubt it's a contact issue - also the write light usually stays on even if your camera is off. But to confirm step 2 on my Mac I used the I/O monitor set that's part of the Xcode suite on my MBP and looked at the device logger to confirm the camera would not register on the original cable. The I/O logger is a separate download from the developer page I believe aside from Xcode, there is also a general USB logger from Apple but it is deprecated.

The original cable still charges the camera however.

 WesH's gear list:WesH's gear list
Sony a6000 Sony E 55-210mm F4.5-6.3 OSS Sony E 16-50mm F3.5-5.6 PZ OSS Sigma 30mm F1.4 for Sony E
Sony a6000
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow