85mm 1.4 GM not recognizable

Started 4 days ago | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
jayfromeast New Member • Posts: 7
85mm 1.4 GM not recognizable

so i saw that 85mm gm i ordered have gotten

here at local distribution center this morning,

I had to take a day off and try this bad boy 😆

But...

I opened the box and put the lens on my a7rii

it made a weird sheeshing sound

it goes shshshshsh beep!

not that loud, so i didn't mind it.

But the real problem is that my A7rii does not

recognize the lens...

I checked my pins on both body ans the lens

they seem fine, I tried other lenses and they work

In the menu, under Version, It only has information

of the camera body. Which means it's not recognizing the lens.

has any of you had the same problem?

maybe a solution? I'm dying here 😔😭

I called sony support, they recommended me to send the lens back.. but she seemed like she had no idea about the camera..

Any tips will be greatly appreciated

Thanks,

Jay

 jayfromeast's gear list:jayfromeast's gear list
Canon EOS 7D Mark II Sony Alpha 7R II Canon EF 50mm f/1.8 II Canon EF 70-200mm f/2.8L IS USM Sony FE 55mm F1.8 +5 more
Sony Alpha 7 Sony Alpha 7R
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow