X-S1 evf issue - Why?

Started 1 week ago | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
JPEG Shooter Contributing Member • Posts: 900
X-S1 evf issue - Why?

Rant mode = ON

Let's say I'm in Shutter Speed Mode on my X-S1 and I look through the viewfinder to take a picture.  I click the shutter and I see the resulting picture on the 'review'.   I decide that it is too bright so I put the camera back up to my eye and spin the dial to increase the shutter speed.  As I turn the dial, I see no change through the viewfinder at this point.  I only see the change AFTER I press the shutter button and take the picture and the 'review' of that darker shot comes up.   Well now I find that it is too dark so I have to repeat the process and dial in a different speed.  By now my subject has moved and I never got an acceptable exposure.

On other cameras I've had with an EVF, in the exact same situation, I could change the shutter speed while looking through the view finder and see the resulting darker image as I'm turning the dial, BEFORE I even take the picture.   Dial in the exact look I want very quickly as I watch it change in the viewfinder.   Which is SO much more helpful!

Does anyone else find this completely annoying?  Why does the X-S1 EVF behave like this?  It has and EVF, but it does not show me WYSIWYG like other cameras I've had/have.  It acts more like and OVF, which I don't like at all.  This drives me nuts and makes it much less enjoyable to use.

-- hide signature --

JPEG Shooter

 JPEG Shooter's gear list:JPEG Shooter's gear list
Panasonic Lumix DMC-FZ50 Fujifilm X-S1 Olympus Tough TG-3 Sony Alpha DSLR-A550 Sony SLT-A57 +2 more
Fujifilm X-S1
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow