Canon XSi: It takes multiple clicks to take a photo

Started 1 month ago | Questions thread
Shop cameras & lenses ▾
deanimator Regular Member • Posts: 167
Re: Canon XSi: It takes multiple clicks to take a photo
1

I had something similar happen to me recently.

80% of what I do is macro in live view with a wired remote, or lately using DSLR Controller on an Android tablet.

The other day I was playing with a used 2x teleconverter I bought from B&H.  Every time I'd hit the shutter release button on the camera, I'd get a click, the viewfinder would go dark and... nothing.

I had recently had the camera and tripod tip over on a table, and was afraid I'd damaged something.  However it worked fine from live view.

I did a little research and was reminded that I'd been using mirror lockup with a 500mm mirror lens to avoid mirror slap.  I reset all of the custom functions, killing mirror lockup.  It worked just fine after that.

You may have inadvertently set something or forgotten that you set it.  Reset the camera back to defaults and see what happens.

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow