Olympus O-MD E-M1stopped working everything is blank

Started Mar 19, 2017 | Questions thread
Gary from Seattle Senior Member • Posts: 2,430
Re: Olympus O-MD E-M1stopped working everything is blank

I had electronic malfunctions which likely included a stuck shutter. My EM-1 worked (for awhile) if I gave the camera more than a tap. I probably slapped the camera with my hand with about a 5-8 pound slap.

Other than that. Take the battery out for awhile, even 24 hours. Put a different battery in. Push to make sure it is seated.

If you see electronic information on the EVF at any point press the shutter. That also worked for me.

The good news is after repair, my EM-1 is working great.

In your case if it continues as is, the problem is easy to diagnose. Mine wasn't. I kept a log of malfunctions, describing them and sent my occasional malfunctioning camera in after I could reliably produce failure.

 Gary from Seattle's gear list:Gary from Seattle's gear list
Olympus E-M1 Olympus M.Zuiko Digital ED 75-300mm 1:4.8-6.7 Olympus M.Zuiko Digital ED 60mm 1:2.8 Macro Panasonic Lumix G X Vario 35-100mm F2.8 OIS Olympus 12-40mm F2.8 +1 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow