Issue with concentric rings on E-M1 Mark II (edited title)

Started 9 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Astrotripper Senior Member • Posts: 4,597
Issue with concentric rings on E-M1 Mark II (edited title)
3

I'm getting more and more sour on this whole Micro 4/3 thing. First was my journey down the rabbit hole with purple fringing .

I finally decided to buy E-M1.2 and deal with fringing issues, since the camera seems to be checking all the right boxes for me.

But now I discovered this:

This is ridiculous, seriously. 3200 EUR and I can't even get a usable kit?

And yes, I tried different raw converters, and even different demosaicing algorithms.

I will test it out more to see if it happens with other lenses, but I suspect this only affects the Leica.

The worst part is that I bought the E-M1.2 at a brick and mortar store (see, I was so sure it would be a perfect choice) and I don't think I can just return it. So it's the Leica that will have to go back. Too bad, I really, really like that lens.

Anyway, looks like the well has been poisoned for me. I can already tell there will be no love for the Oly flagship, as opposed to GM5.

And to be honest, if I had a viable option, I would jump ship right now.

 Astrotripper's gear list:Astrotripper's gear list
Sigma DP2 Merrill Olympus PEN E-PL1 Olympus OM-D E-M10 Panasonic Lumix DMC-GM5 Olympus E-M1 II +17 more
Olympus E-M1 Panasonic Lumix DMC-GM5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
(unknown member)
(unknown member)
GBC
(unknown member)
(unknown member)
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow