Teleconverter x2

Started Mar 7, 2017 | Questions thread
QuietOC
QuietOC Veteran Member • Posts: 4,196
Re: Teleconverter x2

jennyb wrote:

I have just purchased a Tamron x2 teleconverter to use with my Tamron 70-300mm lens on my Sony a58. I don't seem to be able to take pictures in 'auto' mode. I am not a very accomplished photographer and do rely heavily on auto settings at the moment. Is this not an option with a teleconverter or is there a way to fix the problem?

It should take pictures. It sounds like the camera isn't communicating with the lens through the teleconverter. I have a teleconverter with flaky electrical contacts. If I twist it just right it will make contact and the camera will read the lens. If you enable "release without lens" the camera should still take a picture.

If your Tamron is very sharp at 300 mm, it might be usable at 600 mm, but you will be magnifying all the defects in the lens. I find the background rendering looks pretty bad from my 55-300 on a teleconverter.

It is possible the Tamron teleconverter isn't fully compatible with your Tamron lens. AF worked for me with the Kenko DGX teleconverters and the Tamron SP 70-300 USD. I didn't find that lens to me sharp enough at  the long end to be worth using on a teleconverter.

 QuietOC's gear list:QuietOC's gear list
Pentax Q7 Sony a7 III NEX-5T Canon EF 100mm f/2.0 USM Canon EF 28-105mm f/3.5-4.5 II USM +121 more
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow