Sigma 17-70mm f/2.8-4 Dc and MC-11 Converter

Started Jun 2, 2016 | Discussions thread
Arneb Contributing Member • Posts: 525
Re: Sigma 17-70mm f/2.8-4 Dc and MC-11 Converter

grasshpr wrote:

Arneb wrote:

grasshpr wrote:

rocketjacket wrote:

Wondering what the experience of using the Sigma 17-70mm f/2.8-4 Dc and MC-11 Converter is like on an a6000.

Any issues with the lens stabilation? Or any other issues?

I've got the sigma 17-70mm contemporary and MC-11 with the a6300. The sigma 17-70mm is very sharp, which is one of the main reasons why I wanted to explore this direction rather than purchase the super expensive sony 16-70mm. In terms of autofocus, it is pretty snappy in acquiring focus, and the focus accuracy is very good. (...)

So, in short, it seems like a great lens on the a6300!

Have you also tested it on the a6000? Many forum members (like me) haven't yet upgraded :).

I'm also interested in the performance of the a6000 + MC-11 + Canon 10-18 STM. Canon's WA is quite a bit cheaper than the Sony one...

Do you also know whether the AF-C in video works (probably really different results between a6000 and a6300)?

On the A6000, the autofocus is very good, and is faster than if you used the viltrox ii adapter. In terms of autofocus speed compared with the A6300, the combo with A6000 isn't as fast, but I suspect that has to do with the improved focusing speed of the camera and not of the adapter. If your looking to use canon 10-18 STM for the MC-11, you will be disappointed because EF-S lenses won't mechanically fit on the MC-11 adapter.

I just tried using AF-C for video on the A6300, and it doesn't work with MC-11. I personally don't do video on my a6300, but I'm sure others would have like this feature. Hope this helps.

This helps a lot! Thank you very much. It's great to know that the Sigma works well on the a6000 too.

Maybe I'm asking a bit much, but may I ask: how fast is it exactly on the a6000? Around a tenth of a second, like native lenses, around half a second, or more? I suppose AF-C in photo mode doesn't work, as it also doesn't work in video mode?

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow