X-E2 creaking sound when pressing the 'DISP BACK' button

Started Mar 7, 2016 | Discussions thread
ForumParentFirstPrevious
Flat view
David Zamora
David Zamora Regular Member • Posts: 179
X-E2 creaking sound when pressing the 'DISP BACK' button

I just want to make sure this isn't a common problem and that I just happened to get a lemon.

I just received a brand new X-E2 today and it's gorgeous. Shoots great, handles nicely. So, I start pressing all of the buttons on the back because I was so enthralled with the quality 'clicky' sounds. I get to the very bottom 'DISP BACK' button and once I click it, that entire bottom portion of the back panel makes a cheap, plasticky creaking sound. I thought the button just needed some working it, but wasn't the button, it's the panel section around the button that is making the ugly sound.

I was pretty surprised at seeing this, considering how these are hand-made in Japan (I've seen all of the cool factory tour vids). Anyway, has anyone else had this problem? Is this a known issue with this particular model? Or, did I just get unlucky? Still very surprising considering the amount of QA that goes into these cameras.

Here's a video I took so that you can hear the wonderful orchestra of plasticky creaking overtures.

https://www.youtube.com/watch?v=tqVk7U334NM

I've already requested to have it exchanged from Adorama, but if it's a common/known issue, I'll probably just hang on to it.

-- hide signature --

P&S lover extraordinaire
http://www.pocketshooter.com

 David Zamora's gear list:David Zamora's gear list
Fujifilm FinePix F30 Zoom Sigma DP2s Sigma DP3 Merrill Sony RX100 II Nikon D7000 +6 more
Fujifilm X-E2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow