Lens Error- please restart Camera S3 IS

Started Oct 27, 2011 | Discussions thread
DonA2 Senior Member • Posts: 2,929
Re: Lens Error- please restart Camera S3 IS

maumari wrote:

maumari wrote:

AceWildCard wrote:

Got it!!! Yahoo!!!
Here is what I did...

I read all of these threads, and read about the hard reset, tried a couple times and it didn't work... So I said to myself what have I got to lose to try other ideas so I did... I did hard restart with holding zoom in, and zoom out, about 4 times and finally the lense went back in and started working again! I would not try forcing it in any way like some stated. Zooming in while powering and zooming out and also turning it off in between seemed to get it finally. Try it! You have nothing to lose.... (Oh and I took out the little battery and put it back in for the clock, that did nothing).

PS: I had no memory card in the camera (with its door closed) during the entire process.

thank you Ace It worked for me tooo!!!!! 5 times doin it and the camera was back in function

grazie e ciao


30 minutes later the S3 lens got stuck again...

I tried the same procedure but it didn't work. So I put the camera above a radiator for an hour and .... YESSS now it works flawless. But don't ask me why.

I will check later if the S3 will work the same when cooled.



Re the post below by eilivk and the link to many suggested "fixes".

 DonA2's gear list:DonA2's gear list
Canon PowerShot S2 IS Canon PowerShot SX10 IS Canon PowerShot S100 Canon PowerShot SX40 HS Canon PowerShot SX50 HS
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow