Error message E:62:10 in 15 month old HX400v

Started Oct 8, 2015 | User reviews thread
Bill Borne
Bill Borne Forum Pro • Posts: 45,608
Re: Error message E:62:10 in 15 month old HX400v
1

Stephen McDonald wrote:

It doesn't make sense to give a camera model a drastically downgraded rating, just because one of them had a fault develop after more than a year of good service. If an athlete won a race and sprained an ankle after finishing, would the victory be cancelled?

Makes sense to me. That's his opinion and I can see whyh he is frustrated. Again and again over the years I have seen the same problems arise with certain models ans sony just ignores them saying "Out of Warranty". For example the H5 half press problem! Widely know but sony would not repair after warranty. I got bit with that one! So I purchased another one and sent the original one back under the new ones warranty!!!! And gave it to my daughter!!! Sony is and always will be horrible about customer service! That is why I never buy a camera till it's been out for quite a while. I'm sure they fix things in later production runs and never tell anyone!

And that is why I always buy extended accidental warranty. Why accidental? Cause when something does happen and they claim moisture or something I'll Accidentally drop it from  a roof top!

Now That's just my opinion!

-- hide signature --

"Wild Man from Borneo"
Click for Bonehead's Photos

 Bill Borne's gear list:Bill Borne's gear list
Sony Cyber-shot DSC-R1 Sony Cyber-shot DSC-HX400V Sony Cyber-shot DSC-F828 Sony RX100 III Nikon Coolpix P900 +3 more
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow