Yongnou 50mm 1.8 Not Working With Canon EOS 650 (film)

Started Oct 7, 2015 | Questions thread
ForumParentFirstPrevious
Flat view
Tipsy Reactions
Tipsy Reactions New Member • Posts: 9
Yongnou 50mm 1.8 Not Working With Canon EOS 650 (film)

Hey everyone. I purchased a Canon EOS 650 a while back along with a Yongnou 50mm 1.8 lens and I wanted to try and use the two together since the prime was EF mount. I loaded a brand new battery in and cleaned the contacts on both the camera and lens and I got the dreaded "bc" error. Funny thing is, when I used other Canon EF lenses with the camera it worked perfectly. The seller told me that it was in good condition and worked when he used it. Also I bought the lens brand new and works with my 650D in both AF and manual mode.

Has anybody ever had this issue before? I saw somebody over on another website with the exact same setup and asked them about it, though they never responded to me. Maybe just a faulty lens? Ive occasionally gotten a contact error on the 650D before, but that is a very rare happening.

"Wowzers, that lens quality is second to none." -Kai Wong

 Tipsy Reactions's gear list:Tipsy Reactions's gear list
Canon EOS Rebel T4i Canon EF 75-300mm f/4.0-5.6 III USM Canon EF-S 18-55mm f/3.5-5.6 IS STM Gimp Apple iPhone 4S +2 more
ANSWER:
This question has not been answered yet.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow