D750 not responding to some buttons, cannot enter menu / image preview

Started Jul 26, 2015 | Discussions thread
ForumParentFirstPrevious
Flat view
bthblue New Member • Posts: 3
D750 not responding to some buttons, cannot enter menu / image preview

Hi guys.

Another issue with Nikon D750 - three months old, no flare issue serial no. Today it suddenly stopped working correctly. Some functions do work, while others (menu, image browsing) does not.

  1. Photos can be taken, both dials are working and the multiselector for choosing AF point works
  2. Taken photo is displayed on LCD, but the multiselector does not work anymore. Cannot move from photo to photo or change preview mode (stuck in highlights)
  3. Menu, Image review, Info and "i" button on the left-hand side does not work
  4. The following buttons do work: WB, Quality, ISO. They fire up LCD
  5. Both mode seection dials on the left top side work and switch between M/A/S/P and shooting mode (Quiet, Cl, Ch etc).
  6. Live view works properly and I can shoot or records videos
  7. Two green button hard reset would not work or at least there's no reaction at all

I did try to format cards or operate without one. Replaced the battery for couple of hours, tried a spare one (original) - still nothing. I was able to bring up the menu once, but it was not operational.

Any ideas beside sending it in for repair?

Best,
Bartek

Nikon D750
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow