Corrupted CF card; desperate to recover files, urgently.

Started Jan 5, 2015 | Questions thread
ForumParentFirstPrevious
Flat view
James Murray New Member • Posts: 6
Corrupted CF card; desperate to recover files, urgently.

Greetings --

I dearly hope someone can help here:

I shoot with the Canon 7D Mk II (newly acquired, loving it); this past week I shot ~ 1000 images of significant importance.  Last night I decided to take a quick look at some of them by attaching a multi-card reader to my Mac Air, in order to import them into LR (CC).

The first hint of trouble was that the laptop never saw the external card reader as a device. After removing/inserting the CF card several times, I gave up and put  the CF card back into my camera.

It was a sickening feeling when the camera gave the message that the card cannot be read and must be formatted now. (I've been shooting CF cards for at least 7 years with Canon 20D, 7D and now the 7D Mk II without once formatting the CF card.)

The card in question is a Lexar 64GB UDMA 7.

My *normal* workflow is to simply hook the CF card up to a Belkin card reader attached to my Win7 PC, *copy* the. .CR2 files (using Fastone Image viewer) to my workstation's HD, then import using LR with the HD as the source. (I do all of my photo processing on my Windows machine; last night was the first time I've tried copying images to my Mac laptop.)

I am an IT desktop tech, and seems clear that the card reader attached to the Mac corrupted my CF card. THIS IS  NOT GOOD.  I'm praying that the actual images are still on the card, although currently inaccessible due to a corrupted file system o the card.

Win7 does NOT see the card as a valid external drive either.

Thus I've tried 3 applications to recover the files (PhotoRec, Image Recovery, and ZAR). Oh, and the Lexar Image Rescue tool as well.

No success so far.

ZAR seems to show potential, and has garnered broadly good reviews across other forums, but it is horribly slow and I'm beginning to think it too may fail: it eventually is able to find the card by enumerating the drives, then begins a process of analyzing several file tables. However, after spending a huge amount of time analyzing the "GPT volume table" it goes on to scan the RAID table (? - on a CF card?) . . . and, after a more *hours*, does not seem to be making any discernible headway.

It's now 3:30 a.m. and I must get some sleep (work beckons at 9.00 a.m.). These images have potential commercial value for me. I'm now considering contacting professional data recovery firms, blanching at the potential costs there.

I'm seeking ANY advice/direction from the community here; surely I'm far from the first person to have experienced this nightmare. I can be contacted directly at the following email addresses (cc both please if appropriate):

jwmurrayphoto@gmail.com

james.murray@sjsu.edu.

Much thanks in advance.

ANSWER:
This question has not been answered yet.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow