OMD-EM1 Complete Loss of Power: Anyone else?

Started Sep 10, 2014 | Discussions thread
ForumParentFirstPrevious
Flat view
bobbip Regular Member • Posts: 155
OMD-EM1 Complete Loss of Power: Anyone else?

First post here everyone, but after extensive fruitless searching for others with the same problem, am curious about anyone else having a complete loss of power problem with their EM1?

I've found one user (FlashGordon'sMum) with the same problem, but no follow-up post to let us know what happened on the Australian Whirlpool forums: http://forums.whirlpool.net.au/forum-replies.cfm?t=2236067

I have had one of the lemon EM1's with the rear dial issue since January. It's now in the repair shop for the third time: 1. the now, well-known rear-dial issue, was "repaired" by replacing the main board of the camera but manifested again after some use, 2. the rear-dial issue was repaired by replacing "top" of camera and cleaning dials/levers, and 3. anxiously awaiting news on my complete power loss.  (Luckily, I live in Perth, WA and am able to drive/drop off my camera directly to the repair centre.)

I had been using the camera happily for several months since the last repair and was simply videoing my daughter's school assembly, when I noticed the screen was very dark. I continued videoing to the end of her song and turned the camera off thinking I'd check it out when I got home. When I got home, the camera wouldn't power on. I assumed maybe the dark video was due to a depleted battery and proceeded to put another battery in. Still, no power. To make sure, I charged all three of my batteries fully and tried each one, still no power. Thought I'd try to sync it to the computer to see if that would "wake it up." Still no power. Dead.

I do use a combination of 3 batteries:  1 official Olympus and 2-3rd party batteries that have functioned just like the Olympus in the Olympus charger and in the camera (i.e. auto-shut off in the charger works fine and battery life seems equal to Olympus battery).

Anyone else had a power loss or read about others?  If so, can you share your experience or links to the pertinent discussions?

After the second repair of the known issue, I told myself my camera body was probably "better than new" since it had a known technical issue repaired, but now, I'm wondering how/if I should pressure Olympus for a new body????

 bobbip's gear list:bobbip's gear list
Olympus XZ-1 Olympus E-M1 Olympus M.Zuiko Digital ED 12-50mm 1:3.5-6.3 EZ Olympus M.Zuiko ED 75-300mm 1:4.8-6.7 II
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow