Can't format CFII Card in E-510

Started Jul 25, 2014 | Discussions thread
Flat view
Epmusa81 New Member • Posts: 1
Can't format CFII Card in E-510


I've been searching for a decent answer to this question for quite a while now.

I have a CFII card that (for reasons not relevant here) I formatted in windows and loaded a Win7 boot image onto (it was an emergency :p). The camera concerned is an Evolt 510.

After I was done with my "emergency," I could not reformat the card in-camera.

I tried the following:

* A full-format FAT-32 (seeing as the card is 8GB) using a USB reader, and although Windows can read the card, my camera cannot. E-510 simply gave me a "Card Error" upon swtiching on"

* Restoring a complete image to the card, originally made using "USB Image Tool" (which creates an *.img file of USB devices, supposedly including the bootsector, etc.) that I had (sensibly, I thought) made prior to putting the WIn7 image on the card.  Result was that the E-510 could read the images that were in the *.img in playback mode, but still not write to the card or format it ("Card Error" upon any write operation).

* Zeroing the card completely in Linux-based Parted Magic using a full disk erase. Result was "Card Error" on turning the camera on.

I'm lost at this point. It's the second card with which I've had something like this happen -- format n another device and BAM! the card no longer works in camera and can't even be formatted, though there's no problem in Windows.

I find it hard to think this is a FAT problem, or a bootsector issue because I a) tried restoring that full card image and b) zeroed the card.

Is there actually any way to restore a card to it's default virgin state that I'm missing here so that the E-510 can format it as it pleases?

It can't be a hardware error on the card's part because it works fine in Linux and Windows, and it's not a pin error on the camera -- the pins are fine and a new card will format without any issues.

With good, fast cards costing £20 odd and me being on a limited budget, it's frustrating to have lost two cards now simply because I dared to use them in another device.

Does anyone know of any way to reformat the card or restore it to a virgin (i.e. factory) state or why on earth the E-510 would refuse to write to or format the card?

Thanks in advance for any responses

Olympus E-5
If you believe there are incorrect tags, please send us this post using our feedback form.
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow