Fuji X-S1 extremely disapointing

Started Feb 26, 2012 | Discussions thread
photoreddi Veteran Member • Posts: 7,729
Re: Fuji X-S1 extremely disapointing

Dash29 wrote:

...

OK lets try to clarify this.

The thread title ("Fuji X-S1 extremely disapointing") isn't misleading as it fits my feeling exactly.

Now for me not being able to work the camera is somewhat of a silly reply as I'm only pressing the shutter button. Camera is tripod mounted and nothing else is touched.

See below

Well, that's clear enough, although it would be at least a little more reassuring if your photos were shot indoors on a tripod, insuring that the light would be more invariant. I can't explain why your X-S1 isn't behaving like mine and I assume that if most people's X-S1s behaved like yours we'd have heard many more complaints from people also having significantly erratic metering.

I'd suggest using the RESET option in the Setup Menu. If that doesn't help (and if I was having the same problem) the first thing I'd consider would be sending the X-S1 back to Fuji if it was still under warranty and if it isn't, then trying to get Fuji to fix it for a reasonable price. The second thing I'd consider doing would be to buy another new X-S1 if they're available in your location, since the prices are now very low, between 1/2 and 1/3 of the original price, and you should be able send it back for a full refund if it also exposes erratically.

Post (hide subjects) Posted by
HZP
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow