Having trouble updating EM-5 firmware.

Started Jan 29, 2014 | Discussions thread
Bronislaw Wstep New Member • Posts: 1
Re: Having trouble updating EM-5 firmware.

Having the same problem with updating to 2.0 I found that thread yesterday.

I had tried upgrading with and without SD card, with different lenses attached or even no lens at all - no luck.

Finally I found out that my problems were an effect of poor quality of Olympus software (updater) and slow internet link:

I've noticed, that when you plug the USB cable to the camera, upon initiating connection with the PC, camera makes slight noise. Similar noise is to be heard just before the message that program cannot connect to camera. It looks like the camera timeouts the connection with PC when the firmware updater is busy with downloading the software for too long. Observing my internet link confirmed the suspicion: after the license agreement and just before the error occurred the updater was busy with downloading software, saturating my slow (2Mb/s) internet link. The transfer was dropped after the message error.

Using faster link solved the issue - neither card nor lens were problems in my case.
I guess similar issue may arise also in case of faster links when Olympus servers are under heavy load - just after releasing a new version.

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow