"Red Haze" on pictures why? Out of camera Jpegs and fixed samples.

Started Mar 17, 2014 | Questions thread
Shop cameras & lenses ▾
Flat view
thomasw333 Contributing Member • Posts: 512
"Red Haze" on pictures why? Out of camera Jpegs and fixed samples.

Look at my jpegs, they have a red haze over them. I have the OOC Jpegs and then the fixed pictures from Photoshop Elements. The fixed pictures do not have the haze, they look clear. I am just using auto fix in elements to get this result. What am I doing wrong to get this Haze? What is Elements fixing to get rid of it? I like to use Olympus Viewer, it came with my Olympus Camera, I have also used Lightroom, and now, Elements. Elements is the only one of the three with an auto-fix button. But I would like to be able to fix the pictures myself. The auto-fix from Elements looks clearer to me, but maybe a little overshrapened.

So I am looking for feedback on how to not get the haze in camera. And also if people think that I just need to buy a better Post Processing program. I have only used LR and Elements in trials. I have not bought anything yet.

And as always thank you for your time.

OOC Jpeg

Elements Auto Fix

OOC jpeg

-- hide signature --

Lets promote calm rational arguments.

 thomasw333's gear list:thomasw333's gear list
Olympus PEN E-PM2 Canon EOS Rebel SL1 Olympus M.Zuiko Digital 14-42mm 1:3.5-5.6 II R Olympus M.Zuiko Digital ED 40-150mm 1:4-5.6 R Olympus M.Zuiko Digital 17mm 1:1.8
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow