E-M1 just back from repair - hmmm

Started Feb 21, 2014 | Discussions thread
Shop cameras & lenses ▾
rrr_hhh Veteran Member • Posts: 6,020
Re: E-M1 just back from repair - hmmm

brick33308 wrote:

I sent my E-M1 in a couple of weeks ago because it had completely locked up which I reported here: http://www.dpreview.com/forums/post/53036673

When I sent the camera in, I sent in only the body, and didn't send back the original box or anything else. Today I got a different E-M1 (different serial number) which appears to be new, full packaging, new battery, charger, etc. I checked and it has 121 shutter clicks on it.

On the one hand I suppose I should be thrilled that I got a brand new camera. But I can't erase the nagging doubt of whether I would have been better off had they repaired my old camera, addressing the specific problem I had to ensure it never happens again. Instead I've got what appears to be a brand new off the shelf camera (although as I said with 121 clicks - probably just normal factory testing?) and in the back of my mind am wondering if and when I'll experience the same lock up problem. Even worse, if it happens while I'm on vacation (we're going to Iceland in July) then I'll be up the creek so to speak.

Any thoughts?

What ?  You got a brand new camera and you are still complaining ?

-- hide signature --


 rrr_hhh's gear list:rrr_hhh's gear list
Olympus OM-D E-M5 Canon EOS 6D Sony Alpha 7R Olympus E-M5 II Sony Alpha 7R II +4 more
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow