EOS 70D Mode Dial problem...

Started Feb 9, 2014 | Discussions thread
Flat view
patricio7707 New Member • Posts: 7
EOS 70D Mode Dial problem...

Hi ... I'm Patricio from Argentina.

One week ago I received from the U.S. a Canon EOS 70D.

It worked ok until yesterday.

Since today, when I want to choose different modes with the dial mode, the camera just sets: P or A+ (auto).

- If I select A+ mode (Auto mode) or "Disabling Flash mode" or "Manual mode" .... the camera sets as A+ (Auto mode).

- If I select modes: CA, SCN, C, B, AV, TV, or P ... the camera sets as "P mode".

I have read some similar cases in other models of EOS cameras ... they recommen do a "hard reset" by removing the main battery and clock battery.

I tried to do that, but this model (EOS 70D) seems to have a battery for the date and clock ... but it is internal, It`s a rechargeable battery.

I guess as a new model, there is no more than the actual firmware, that comes from factory ... so I can`t try to update, since there is no other firmware available.

Anyone have any suggestions before taking it for service?


you can see what's wrong with my 70D here: (the mode selected by the dial, it's not the same on the screen)

Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow