7D USB port suddenly didn't function

Started Feb 6, 2014 | Questions thread
Sherwin V Ubaldo
OP Sherwin V Ubaldo Forum Member • Posts: 58
Re: Still Dead USB but Audio & Video Cable provided works via USB port!

I did removed the clock and LP-E6 battery for more than 24 hours... I reset all settings even custom settings to default before I did and still not detected.
I tried it on a Mac Book Pro and 2 more desktops in the studio still not detected which was easily connected for the past 3 years I have the camera.
One thing I did thou is to connect the camera using the composite Video and Audio Cable provided and it was all okay and that is using the USB port of the camera.
It couldn't be possible that all 3 other computers are having registry errors all at the same time plus the laptop that was used during the shoot?
I guess this is electronic/hardware related problem with the 7D (Sigh)

-- hide signature --

Just do your best at all times. Sick or not.

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow