F20M and F43m Flashes with A7 wireless setup so limited?

Started Jan 25, 2014 | Discussions thread
ForumParentFirstPrevious
Flat view
zither Regular Member • Posts: 240
F20M and F43m Flashes with A7 wireless setup so limited?

I was trying to use F20M on my A7 as the trigger for F43m. The F43m is only triggered when set A7 to WL flash mode. But at the same time, the F20M will NOT contribute to the exposure no matter what flash comp I set on A7 body. When I set A7 flash mode reguler/slow/rear/ modes, the F43m will not be triggered at all. The F43m setting like RMT1 or RMT2 doesn't change anything.

So overall, the F20m can only serve as pure trigger, and I still just got one light source from a different position. Plus my RX100II cannot trigger F43m at all with either build-in flash or F20m mounted.

I mean seriously?? My cheap Youngnuo flash can be triggered on all above situations with or without exposure contribution from build-in flash. And the price is 1/6 of F43m.

Hmm.....If I'm not setting anything wrong, I'd really think of getting anther Youngnuo and sell the F43m.

 zither's gear list:zither's gear list
Sony RX100 IV Sony Alpha a7R II Sony FE 55mm F1.8 Fujifilm XF 10-24mm F4 R OIS Sony Vario-Tessar T* FE 16-35mm F4 ZA OSS +1 more
Sony Alpha a7 Sony RX100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow