New version of Aperture announced!

Started Oct 22, 2013 | Discussions thread
Mr Grinch Contributing Member • Posts: 633
Warning about version 3.5 before you upgrade.

Be careful, if you upgrade to 3.5, your libraries will not be compatible with any other version of Aperture. If you have an older mac that won't run Mavricks, you won't be able to export, import and merge libraries on separate machines that aren't able to run 3.5 order to work or collaborate on a laptop/desktop configuration.

I've got an older Mac Pro that won't run Mavericks, and a newer MBA that I take on the road during shoots. Had I upgraded, I would have been in a world of hurt until I get a desktop that will run Mavricks.

Post (hide subjects) Posted by
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow