SkinSmooth for Photoshop

Started Aug 6, 2013 | Discussions thread
OP PhotonMayhem Forum Member • Posts: 54
Re: SkinSmooth for Photoshop

Reminder to anyone who has version 1.3 or less.

Legacy versions 1.3 and less are not CC compatible and if you ever intent to use CC you should update to version 1.5 (CC compatible) as soon as possible.
this upgrade is free

In five days version 1.5 will be retracted and it will not be possible to upgrade to it anymore.
(upgrading from versions 1.* to 2.* is not possible)
so please do not complain if you don't upgrade on time

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow