Hi. Any ideas about this weird K30 behavior?

Started Aug 2, 2013 | Questions thread
Shop cameras & lenses ▾
Flat view
Marriott Senior Member • Posts: 1,669
Hi. Any ideas about this weird K30 behavior?

My K30 is exhibiting some frustrating behavior. In all exposure and metering modes at 0.00ev and a single center focal point, I have been getting wildly different exposures shooting the same scene. Here are some test shots converted in LR 5 at standard defaults using the DA 70 2.4, but all my lenses are doing this:

1/250, f/2.4 ISO200

1/125, f/2.4, ISO100


1/400, f/2.4, ISO 200

1/160, f/2.4, ISO 100

1/400, f2.4, ISO 100

and, using live-view:

1/10, f/2.4, ISO 100

It's all over the map. I've had my K30 for one year tomorrow. I had a K5 before that which had the "mirror flop" problem. I'm feeling a little snake-bit. This has been a very helpful forum for issues in the past, so I hope some ideas can be of service. Thanks.

 Marriott's gear list:Marriott's gear list
Panasonic Lumix DMC-GX7 Olympus OM-D E-M10 II Panasonic Lumix G X Vario PZ 45-175mm F4.0-5.6 ASPH OIS Sigma 60mm F2.8 DN Art Panasonic Lumix G Vario HD 12-32mm F3.5-5.6 Mega OIS +6 more
This question has not been answered yet.
Pentax K-30 Pentax K-5
If you believe there are incorrect tags, please send us this post using our feedback form.
Flat view
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow