X-rite i1Display Pro cannot be found

Started Jul 21, 2013 | Discussions thread
Shop cameras & lenses ▾
Flat view
Alfred Molon Senior Member • Posts: 1,129
X-rite i1Display Pro cannot be found

I installed the x-rite i1Display Pro in June on my computer (Sony Vaio S15 with Windows 8 ).

Initially it worked fine. Then a couple of days ago there was a software update and since then the i1Profiler software tells me it cannot find the i1Display Pro. I've searched the web for answers, been in touch with x-rite customer support and tried the following:

- uninstalled and reinstalled several times, trying two different version of i1Profiler (the most recent one and the 1.1.1 if I'm not mistaken)
- trying initially disabling the antivirus SW, then I uninstalled it
- installed the XRD manager 2.3

All this didn't work.

I've even used USBDeview to uninstall the device from the USB ports. Afte that, when plugging it in, you could see that some SW installation for a "i1Display 3 Pro" was successfully happening, but I can't see the i1Display Pro in the Hardware Manager.

The i1Display seems to be correctly recognised by the computer (shows up in the device list when I plug it in.

Do you have any suggestion about what else I can do?

Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow