Meike MK-D5100 no longer functioning after upgrading distortion control data

Started Jul 20, 2013 | Questions thread
BirgerH Veteran Member • Posts: 5,904
Re: Meike MK-D5100 no longer functioning after upgrading distortion control data

Piotr70 wrote:

BirgerH wrote:

Piotr70 wrote:

Is there someone else that is facing the same problem?

I used to have my battery grip always on, with two original Nikon EN-EL14 battery packs. Never had any problem until I upgraded distortion control data firmware to 1.009. Immediately after upgrading, the camera said I must use compatible batteries in order to work. If I unfit the grip and use raw batteries, no problems arise. So the problem must be the grip-to-camera connection with new firmware. But I'm reluctant to accept that a distortion control data software that only applies to jpeg images is affecting other camera functions.

What can I do? Since I'm a RAW shooter, I'm really not interested in correcting distorion in-camera for lenses that I'm not having. Is it possible to rollback to a previous firmware version?

Thanks for your help


Hi Pietro.

Like you I can't believe, that this update affects the battery-grip.

Now I don't dare to do the upgrade - I too use Meike on my cameras.

I would try this:

Recharge battery fully.

Do you have a setting choosing which batteries to use - check that - should be set to MD-5100 - could have been changed if the camera makes a reset after updating. (Don't have a D5100 - don't know the menus)

Does the green battery-indikator blink once, when you connect the grip? It should to show, the connection is allright.

Try to do a manufactory reset (using the menu).

I don't think you can go back from the upgrading.


Hi BirgerH

I'm probably very unlucky, and the firmware upgrade was only a coincidence. That's what I did:

- restored factory defaults: nope, doesn't work

- reinstalled firmware 1.01: nope (only updates A and B chips), doesn't work as expected

- coundn't find previous distortion control data firmware, or I would have downgraded that too

- unmounted everything: lens, battery grip, batteries, memory card, silicon cover, ...everything.

- Mounted again in this order: lens, memory card, raw battery in camera battery slot (no battery grip). Switched on the camera. OK.

- switched off, swapped batteries. Switched on. OK

- unplugged battery from camera, inserted battery grip with no batteries. No signal from camera. Switched on, no signal as expected

And now the final test:

- suspend breathing. With the battery grip plugged, camera off: opened battery compartment door, inserted one battery.... OK, battery accepted. Insert the second battery. OK, battery accepted.

The problem is solved.

The distortion control data firmware seems to be innocent.

Ohh - glad to hear its solved.

I think its the correct way to connect the battery-grip - without batteries - and then putting in batteries next.


 BirgerH's gear list:BirgerH's gear list
Nikon D90 Nikon D7000 Nikon D800
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow