Toshiba FlashAir Card in E-PM2 and Olympus OI.Share iOS app.

Started Jul 13, 2013 | Discussions thread
Flat view
dave rogers Regular Member • Posts: 384
Toshiba FlashAir Card in E-PM2 and Olympus OI.Share iOS app.

This post is intended to perhaps clarify any confusion regarding the capabilities and uses of the above products. (This could be my confusion; though I think I understand this now.)

I installed the Olympus OI.Share iOS app on my iPhone 5 shortly after the app was released. I've enjoyed playing around with the art filters on images I've taken with my iPhone.

After Oly announced the E-P5, and demonstrated its built-in wifi capabilities with the OI.Share app, I formed an impression in my mind that the same capability would be available to the most recent generation of PENs using the Toshiba FlashAir card and the OI.Share app. That impression is incorrect.

The FlashAir card will work in the E-PM2, but it does not provide the same "built-in" functionality that the E-P5 provides. You can't operate the camera by wireless remote control; you will not have the QR code "easy setup" option; nor can you geotag an image using gps data from your phone.

The FlashAir will allow you to transfer files to your iOS device, using the OI.Share app. You could also just use the web browser to do the same thing.

I had difficulty initially connecting the iPhone and the FlashAir. As shipped, my card was configured to not auto-start. You can change that using the camera by by protecting or unprotecting a default image that is stored on that card specifically to toggle that functionality. That doesn't seem to be in the instructions, at least, I didn't see it.

The card is supposed to have the configuration utility for a Mac or PC stored on the card. The card I received had only the PC version. I downloaded the Mac version from Toshiba's support page .

I used the utility to toggle the card to auto-start. Then changed the SSID to delete the MAC address. I kept the default password which is simply 12345678.

The network controls for the camera are in the Playback menu items. When I re-inserted the card into the camera, the green wifi icon appeared on the LCD, which had not appeared before. I was able to select the FlashAir network in my wifi settings on my phone and network with the device. (Update: I'm not really sure what's going on here. But in subsequent efforts to check various menus and settings while writing this post, the green wifi icon did not come on until I went to the Playback Menu and selected a connection. I suppose that may be a power saving feature that toggles the network circuitry on and off. So maybe it'll auto start, once so configured, the first time. Then you have to start it in the Playback menu, once you have it configured for your camera.)

But when I went to the network controls in the Playback menu on the E-PM2, the camera complained that since the card had not been configured on the camera, it couldn't "change" anything. I'm not sure what it wanted to change.

Upon reading this complaint, I removed the card and inserted it back into my laptop and used the configuration utility to reformat the card. This is supposed to return it to factory defaults.

Once again, I selected the auto-start, but I didn't change anything else. The format option also removed the PC version of the utility software, but added another folder with three versions of .png icons for the card, and a small .txt file of data.

Back into the camera. Network is on, joined it with the iPhone, and this time I got the configuration screen in the Playback menu. I didn't really want to change anything, so I moved the cursor to the END key of the virtual keyboard, and that dumped me out of the SSID field and put me in the password field, which was blank. I entered the default 12345678 password, and hit END again. Then all the options were available in the menu. I selected a Private Connection (I haven't tried to figure out the One-Time Connection yet.), and then returned to Olympus OI.Share app.

The bottom tab of the app showed still showed the camera wifi as "off." I went to the Safari browser and entered the URL for the card http://flashair/ and verified that the browser could see the card. It could. I returned to OI.Share, and still saw "Off." I snapped an image, just out of frustration more than anything, and all of a sudden, the app recognized the camera. I selected Remote Control, and got the "built-in wifi camera required" error. Finally figured out that really meant "built-in." Selected Import Photos and got a screen full of images to select. Tap one and you get the wait cursor while it downloads the image, then you can choose to save it to your Camera Roll. A finger swipe takes you forward or backward through the images, though there are redundant arrow icons to perform the same function with a tap. Perhaps an accessibility feature.

You have to save the images to your camera roll to do anything to them, so I'm not sure there's any advantage to using the OI.Share app over Safari as far as import is concerned. It will allow you to import full-sized images, but any edited versions are down sampled.

I'd like to think I'm fairly knowledgeable about this kind of technology, I'm certainly not intimidated by it, but this seemed to be far more difficult and confusing than it probably had to be. That said, it has been a much more successful effort with the Toshiba product than I've had with my Eye-Fi card, which I have by and large given up on ever getting to work reliably.

Another somewhat interesting note: The Toshiba FlashAir isn't rated by Toshiba to work in the E-PM1 or the E-M5. I've never tried my Eye-Fi in the E-M5, but it did work (to the extent that it ever worked) in my E-PM1.

If anyone has any experience with these products and can help clarify any areas I may have made needlessly confusing, please chime in.

 dave rogers's gear list:dave rogers's gear list
Olympus C-5050 Zoom Olympus C-5060 Wide Zoom Olympus C-8080 Wide Zoom Olympus XZ-1 Olympus XZ-2 iHS +29 more
Olympus PEN E-P5 Olympus PEN E-PM1 Olympus PEN E-PM2
If you believe there are incorrect tags, please send us this post using our feedback form.
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow