7d problem shows "Err CF" and "Cannot write to card"

Started Jul 12, 2013 | Questions thread
Flat view
Grogly Contributing Member • Posts: 578
7d problem shows "Err CF" and "Cannot write to card"

Hi All,

I am in a bit of a panic because my 7D has the above errors associated with my CF function. The top display says "Err CF" and the back display says "Cannot write to card." Anybody seen this before and found a way around it?

Here is what I have tried:

I have 3 CF cards, all have the exact same behavior error as mentioned above. The camera will lock all functions except for menu operations.

I have removed the battery and replaced it.

I am able to read the cards while in the camera and view files on them, so I am pretty sure that they are not the problem.

I removed the card and changed the mode to allow shooting without the card and the camera behaves normally and the shutter will fire, AF works and IS works on my lens.

I have changed operational modes using the mode dial, no difference in behavior

I have changed from my normal RAW mode to JPG and back with no change in behavior.

Live view has the same error messages.

Removing the lens and replacing it has the same error messages.

I have inspected the pins on the DF connector internal to the card slot and they look normal, no bent pins.

That's all I can think of now, I have done other things though. Thanks in advance for your help.

-- hide signature --

Photographic hack since 1969.
Samples of my favorite images can be found here:

 Grogly's gear list:Grogly's gear list
Canon PowerShot G10 Canon EOS 5D Mark III Canon EOS M Canon EF 28mm f/1.8 USM Canon EF 50mm f/1.4 USM +10 more
This question has not been answered yet.
Canon EOS 7D
If you believe there are incorrect tags, please send us this post using our feedback form.
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow