Yongnuo YN-622N together with Nikon SB-800 buggy?

Started May 30, 2013 | Discussions thread
macadphotos New Member • Posts: 5
Re: Yongnuo YN-622N together with Nikon SB-800 buggy?
1

Yup, I just bought it today. TTL does not work with SB800, it either under exposes or over exposes, and it seems quite inconsistent. It doesn't matter if the flash is on the receiver, or on the transmitter using ttl-pass through. The only time it exposes well is when the flash points exactly where the lens sees (no bounce).  Manual mode works fine though.

If your lighting system requires SB800, think twice before you buy. Hopefully, there will be a fix, though I foresee that it'll be a chore getting it exchanged.

Sb700 works fine with the trigger in all modes.

Arnie47 wrote:

Has onybody tried the Yongnuo YN-622N together with the Nikon SB-800 flash units?

I tried it and have found out that the SB-800s do not work together with the YB-622N in TTL mode. The pre-flashes are sent out but the information for the main flash seems to be transmitted corruptly so the main flash doesn't trigger. Manual mode works correctly.

The YN-622N does work correctly in all modes together with the Nikon SB-700 flashes in my setup.

Can anybody confirm this behaviour?

Is there a workaround or a setup option to make the SB-800 also work correctly in TTL mode connected via the YN-622N?

Post (hide subjects) Posted by
(unknown member)
PKY
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow