Can't delete Aperture trash, any ideas?

Started May 3, 2013 | Questions thread
Jacques Cornell
Jacques Cornell Veteran Member • Posts: 9,260
Drive permissions, new library

increments wrote:

I recently began the process of upgrading my 2009 Macbook Pro to Mountain Lion.
Step 1 was install Snow Leopard and update apps to the latest versions supported. i thought that had all gone reassuringly well...
OS and Aperture both working as well as with Leopard or a bit better.
Today though, I finished working on my latest project and tried to delete the photos in the Aperture trash. Unfortunately, when I select "empty Aperture Trash" nothing happens. The usual dialogue box doesn't even appear.
I've tried repairing and rebuilding Aperture libraries/permissions, as well as doing the same for my hard disk.
No joy.
I've looked on the apple support pages and have seen this happen to a few others, who have ended up doing clean installs.

If anyone has any ideas that would avoid having to do a clean OS install, I'd be very grateful.

Using Aperture since v1.0, I've never seen this, but here's a thought. If the photos are referenced and kept on an external hard drive, you might select the drive, hit command-I (Get Info), and make sure the "Ignore ownership on this volume" box is checked.

If that doesn't work, try making a new, empty library, then importing the problem library into it. This has helped me once or twice with corrupted libraries.

-- hide signature --

'No matter where you go, there you are.'

 Jacques Cornell's gear list:Jacques Cornell's gear list
Panasonic Lumix DMC-GX7 Panasonic Lumix G Vario 7-14mm F4 ASPH Olympus M.Zuiko Digital 45mm F1.8 Olympus M.Zuiko Digital ED 12mm 1:2 Panasonic 12-35mm F2.8 +29 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow