Can't delete Aperture trash, any ideas?

Started May 3, 2013 | Questions thread
Shop cameras & lenses ▾
Flat view
increments Regular Member • Posts: 278
Can't delete Aperture trash, any ideas?

I recently began the process of upgrading my 2009 Macbook Pro to Mountain Lion.
Step 1 was install Snow Leopard and update apps to the latest versions supported. i thought that had all gone reassuringly well...
OS and Aperture both working as well as with Leopard or a bit better.
Today though, I finished working on my latest project and tried to delete the photos in the Aperture trash. Unfortunately, when I select "empty Aperture Trash" nothing happens. The usual dialogue box doesn't even appear.
I've tried repairing and rebuilding Aperture libraries/permissions, as well as doing the same for my hard disk.
No joy.
I've looked on the apple support pages and have seen this happen to a few others, who have ended up doing clean installs.

If anyone has any ideas that would avoid having to do a clean OS install, I'd be very grateful.

Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow