LR 4.3 to 4.4 upgrade installation problems/question

Started Apr 6, 2013 | Discussions thread
OP Dan_168 Veteran Member • Posts: 7,635
Re: Here is the solution for you

noirdesir wrote:

Dan_168 wrote:

1. I deleted the whole "adobe Photoshop LightRoom" from application folder, then run that downloaded 4.4 dmg file, the application got installed, and when I tried to call it up, it ask for serial number, hummm, I purchased the application from Mac App Store so I don't have a CD or box so I don't have serial number written down anywhere.

I think I know what your problem is. Your are trying to update a version of LR that was purchased through the Mac App Store with an updater that was made for the version downloadable from Adobe's website.

In short, open the Mac App Store app and select the Updates 'tab'.

Although functionally the same, their license verification check is obviously different. For the version that you have this done through Apple (ie, OS X make sure you have actually bought it before allowing you to run it). Essentially you have to be logged into the account in the Mac App Store with which you purchased the app when you launch the app for the first time (if are not logged in, you will be prompted to do so when you try to launch the app).

For the version sold via Adobe's website, DRM is enforced via a serial number (not sure whether it also involves a phoning home to Adobe).

Mac App Store apps are updated through the App Store app only. This is to ensure that apps including updates go through Apple's app review process. The point of the Mac App Store is to create a trusted source of applications, with a very simple payment process (you click on buy and that's it), and an easy way to update all applications by checking in only one place (the App Store app) that is a one click process as well (there are a few advantages).

So, obviously, the downloaded updater cannot update your Mac App Store copy of LR. It is essentially a bug that the installer runs at all and claims to have succeeded.

2. I tried to rename the current version 4.3 folder to something else, then run the version 4.4 dmg file again, the installation went thru fine again and at the end system says application install successful but when I looked at the application folder, I didn't see any update show up there based on date and time stamp. so what is going on?? I have never had this kind of issue before, so I am totally lost there.

Again, from the above it should be clear why this doesn't work, ie, why you don't have a serial number ... because the DRM for your version of LR is handled through Apple. That is another point of the Mac App Store, you don't have remember or file multiple serial numbers, one account password (the Apple ID) is all you have to remember.

Thanks a lot for the detail feedback, I think you nailed the problem, however, the solution offered didn't work, I signed into the Mac App Store, went into the "Updated" tab, other than a few totally none related Apple software update, no LightRoom or any Adobe update shown there.

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow