Any Problem Using Two External USB-Powered HDDs on rMBP?

Started Mar 29, 2013 | Discussions thread
Najinsky Veteran Member • Posts: 5,739
Re: Un-mounting Drives Before Sleep-Mode

RustierOne wrote:

Najinsky wrote:

Both your devices are none Apple and fall within their respective USB standards. So you can connect them in any order, plug and un-plug without rebooting (but storage needs un-mounting), and so forth, you shouldn't see any difference or have any problems.

Thanks Najinski for your relies. They have fully answered my original question.

They bring up another problem I'm encountering - un-mounting all drives and partitions before entering sleep mode. When I manually enter sleep mode (closing the lid) I'm un-mounting all partitions and drives first. But sometimes when the laptop is unattended for a while it enters sleep mode without the drives/partitions being unmounted. When I wake-up the machine, there's warning message to un-mount the drives first.

Do you know of any workaround for this problem, other than just setting the time before sleep to be longer?

Steve Jobs wrote an article about Adobe Flash in which he claimed it was the number one reason why Macs crashed. I haven't seen any actual figures on it, but my bet would be that the number 2 reason is USB.

It shouldn't be happening like that, but rather than spend a lot of time hunting down the problem, it might be simpler just to install Jettison from the App store for $1.99. This intercepts sleep mode, ejects any external drives, and re-mounts them on wake-up.

As to the cause of the problem:

In sleep mode, the ports should still be supplying power so the drives should remain mounted. This would be important it you were using the Power Nap feature to do Time Machine Backups while the computer sleeps.

If your rMBP is from 2012, it's worth checking it has the SMC update installed .

It's worth noting the energy saver settings (system preferences) too, specifically the check box for 'put hard disks to sleep when possible'. If it's checked, try unchecking it or vice versa.

Possibly the drives firmware has its own sleep feature and takes too long to wake when the Mac wakes, causing them to appear unmounted. If you installed any config software for the drives, try running it and seeing if there are any settings for controlling the sleep behaviour.

Until recently, my 2010 MacBook Air was running a system that had been repeatedly migrated over the years from a Mac originally running OS X 10.2 from way back when. Everything was fine except USB. Plugging in a USB devices would sometimes (it seemed completely random) kill all hardware input on the machine (keyboard/mouse/trackpad would stop working). The only options were a hard reset via the power button, or remote desktop into the machine to restart it (if I was in the middle of something and didn't want to risk a hard reset).

I've had all manner of USB devices hooked up over the years (colorimeters, serial ports, modems, network ports, hard drives, floppy drives, CD drives, cameras, robots, phones, scanning pens, drawing tablets, and probably half a dozen more I've forgotten). I assumed an old USB driver got migrated to the MBA and caused USB to randomly crash when plugging in a device. So when I got my new 13" rMBP I set it up from scratch, rather than use Migration Assistant. I also formatted the MBA's internal SDD and did a clean install on that. Neither machine has had a problem since, so I'm now fairly confident it was an old USB driver causing the issue.

The fact you reported that system report is showing 0 mA and 2 mA for your USB drives (and now this un-mounting issue) leads me to believe you may have a USB driver problem too. So I'd check the suppliers websites for all your USB devices and check for updated software, and also check if you have any old USB device related software you no longer use and see if you can uninstall it.


Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow