a99 HOT SHOE does not FIT Radio Trigger and Flashes

Started Mar 28, 2013 | Discussions thread
OldClicker Senior Member • Posts: 2,322
Re: a99 HOT SHOE does not FIT Radio Trigger and Flashes
1

Steve West wrote:

OldClicker wrote:

I see we have taken a user error thread and expanded it into ANOTHER exaggerated rant about Sony's switch to the standard shoe.  Sony updates a 25 year old electronic connection with full backward/forward compatibility and yet the sky is falling.  I can see not liking it (I have 6 flashes with the proprietary shoe plus the ring/twin controller), but it exists and it works so shouldn't we move on?

-- hide signature --

Some would have you believe that having to adapt to new technology is a workaround, but having adapted to old technology is photography.

Huh?  A 1/4 to 1/3 sec delay between the preflash and main wireless flash is OK to you? Sony's own main wireless system scrapped so people can mount flashes that are not capable of wireless or HSS?  Now I have to buy a 3rd party expensive replacement to get rid of the HUGE preflash wireless delay.

Did the A99 flash people get fired yet?

Why not make the 1980 flashes use the damned cheap adapter??

More misdirection and hysteria.

The delay (which is a problem) has nothing to do with the shoe.

Sony's wireless system works just fine with the new shoe being both forward and backward compatible.

I haven't a clue what the '80s thing is about.

-- hide signature --

Some would have you believe that having to adapt to new technology is a workaround, but having adapted to old technology is photography.

Post (hide subjects) Posted by
RVN
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow