Help me revive and old GRD

Started Mar 11, 2013 | Discussions thread
Flat view
Janarto Forum Member • Posts: 58
Help me revive and old GRD

Hi there,

I recently found for free an old grd that was damaged after falling to the ground

The rear screen is broken, not readable but is lighting up.

The "busy" led is also blinking.

Flash is starting up, the camera is apparently taking photographs and is starting / shuting down by itself.

Yet i can't access either the firmware nor files in the internal memory.

When i'm pluging it to my linux box, the camera is identified

$ lsusb
Bus 002 Device 005: ID 05ca:2218 Ricoh Co., Ltd

Yet i can't access it

$ lsusb -v
Bus 002 Device 005: ID 05ca:2218 Ricoh Co., Ltd
Couldn't open device, some information will be missing

I suspect it is because of some issues in the config file (not prepared to be opened with usb ?)

i tried a factory reset but i'm not sure it worked as i can't read the screen so i can't know if it was done or not.

Do you have any idea on how to reset it and try to access it from the pc as i could check if i can update the firmware, if photos are taken and if it worth it for me to buy and install an new rear screen

best and thanks for your help

Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow