Strange SPP .JPG problem

Started Aug 5, 2012 | Discussions thread
OP Arky Regular Member • Posts: 433
Re: Ever resolved?

PicOne wrote:

Arky wrote:

PicOne wrote:

Arky wrote:

SandyF wrote:

Arky wrote:

SPP will not save an .X3F file to .JPG. It will however save an .X3F to a .TIF file. SPP will then open the .TIF file and save it as a .JPG.

SPP will "Convert to JPEG file" (extract) from a .X3F file. If I then process a file and save to a .JPG, SPP will ask if I want to replace the existing .JPG. Clicking yes will delete the existing (extracted) .JPG file.

change the name slightly of the file to avoid deleting the first (extracted) jpeg. Put v2 for example, or 'edit' in the title. then save, you'll have both.

Yes, of course that prevents the converted to JPEG file from being deleted but it doesn't result in a saved .JPG file with the different name.

Incidentally, if I save an entire folder of .X3Fs to .JPG the file names appear temporarily in windows explorer (while being written) but disappear when SPP moves on to the next file. It seems as if the .JPG files are indeed being written but are immediately deleted by SPP.

Version and version 5.3.1 of SPP exhibit the same behavior.

I never had a problem with SPP5.2.1 or any earlier versions. I haven't had a change to download the latest SPP yet though.

I'm running win7 64 bit. Since I invariably save to .TIF anyway, I'm not sure if this is a new development or if my machine has always exhibited this limitation.

I always save as jpeg for online, tiff occasionally for big prints.

This is obviously not a huge problem but I was wondering if anyone has seen this behavior before and if there is a simple fix for it.
Any insight would be appreciated.

Best regards, Sandy (archival) (current)

Sorry to bring up an "old" thread.. but I'm having a Save As issue out of SPP 5.5 when trying to go to Jpeg (Tif is fine).. was this resolved (a fix identified) and/or old news and a known issue?

No, this issue has not been resolved. I still have this problem with all versions of SPP. I cant understand why SPP will open a .TIF and save it as a .JPEG but it won't process or convert a .JPEG directly from the .X3F file.

So you didn't determine a means to fix; but did you find out whether this is in fact "normal" for all users, or must be some settings in your (our) PC or something else that's the cause?

I'd like to know if you and I are unique in this regard, or whether a known issue. ANYONE?

I thought I was the ​only​ one with this problem until you chimed in.:-)

I have tried everything I know. I have uninstalled SPP and then opened regedit and deleted everything that mentions Sigma, .x3f or photopro. Then I reinstall SPP and restart my machine. Even after all that, when I run SPP it still remembers and opens the last folder I was working in. I must be leaving something intact in the registry for it to remember the last opened folder, but I don't know what.

I have just decided to live with it, as I mentioned SPP will extract the imbedded .JPEG from the .X3F and it will save a .JPEG from it's own .TIF. Creating a processed .JPEG in SPP is a two step process for me, first make the .TIF and then open the .TIF. in SPP and save as a .JPEG.

If you do find a solution let me know though.;-)

 Arky's gear list:Arky's gear list
Sigma SD1 Merrill Sigma DP1s Canon EOS-1D Mark II Canon EOS 50D Sigma SD14 +14 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow