Problem with OMD and Metz flash in RC mode

Started Dec 13, 2012 | Discussions thread
OP caloymiranda Regular Member • Posts: 315
Re: Problem with OMD and Metz flash in RC mode

FrankParis wrote:

caloymiranda wrote:

FrankParis wrote:

I wonder why the Metz 15 MS-1 has worked (only in RC mode) for me the first time I tried months ago? This is a dedicated wireless slave macro (shaped like a ring) flash. It's just about the most transparent flash I've ever worked with. It just works. I've only tested it in TTL mode however.

Hi Frank,

TTL usually works fine based on my tests. The problem lies on using M mode.


TTL is orthogonal to M mode. I always shoot TTL in M mode.

I'm not sure i quite understand but i was referring to M mode on the RC control panel where you get to set your own value for flash strength (from 1/1 to 1/128).  TTL works fine, M mode doesn't.  The fact that it works on my e-pl2 makes me think it can be solved by a firmware update.

 caloymiranda's gear list:caloymiranda's gear list
Olympus PEN E-PL2 Olympus OM-D E-M5 Panasonic Lumix G 20mm F1.7 ASPH Olympus M.Zuiko Digital ED 40-150mm 1:4-5.6 Olympus M.Zuiko Digital 14-42mm 1:3.5-5.6 II +4 more
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow