Problem with OMD and Metz flash in RC mode

Started Dec 13, 2012 | Discussions thread
ForumParentFirstPrevious
Flat view
caloymiranda Regular Member • Posts: 315
Problem with OMD and Metz flash in RC mode

Hey Guys,
I just discovered this problem and have been searching for a solution without much success.

I did find one other guy with the same problem as me but sadly no one responded to his query.  here is the link:

http://www.mu-43.com/f106/problem-my-omd-metz-af50-during-off-camera-flash-32111/

So here is the skinny:

I tried using a Metz 44 AF-1 in RC mode with my OMD.  Group A, channel 1, clip on flash active

  • If I use TTL mode, the flash fires every single time i press the shutter however, it does not always illuminate my subject, indicating some problems with sync
  • If I set it to M mode, it doesn't fire at all.  i tried changing channels without any success

Has anyone experienced something similar?

By the way, i have an e-pl2 and the flash works perfectly on it every single time.

My OMD has the latest firmware while the metz flash does not have any updates available.

Any input or feedback would be greatly appreciated.

Thanks,

Carlo

 caloymiranda's gear list:caloymiranda's gear list
Olympus PEN E-PL2 Olympus OM-D E-M5 Panasonic Lumix G 20mm F1.7 ASPH Olympus M.Zuiko Digital ED 40-150mm 1:4-5.6 Olympus M.Zuiko Digital 14-42mm 1:3.5-5.6 II +4 more
Olympus PEN E-PL2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow