Cmd/Opt Double Clicking on Aperture library file does not open Restore Library dialog

Started Dec 11, 2012 | Discussions thread
Flat view
Bobolink Forum Member • Posts: 70
Cmd/Opt Double Clicking on Aperture library file does not open Restore Library dialog


I am running Aperture 3.2.4 on an early 2008 15" Macbook Pro (2.4 GHz): OS X 10.6.8 (Snow Leopard).  All my photos are Referenced images.  My Logic Board failed and I had it replaced with a new one in July, 2012.  Now, when I try to work on any image before the new logic board was installed, Aperture says "Can't locate master."  The same thing happened to me a couple years ago when I replaced a crashed hard drive.  At that time I still had Applecare and they walked me through the whole process (Yes, with Applecare you get free tech support on just about anything Apple, not just hardware issues, for free!).  I don't remember all the details, but I did end up repairing my Aperture library.
So I look up how do do this in the PDF manual and it says:
To repair or rebuild your Aperture library
1) Close Aperture, if it’s open.
2) Locate the Aperture library you want to fix, then hold down the Command and Option keys while double-clicking the Aperture library. The Aperture Library First Aid dialog appears.
Only it DOESN'T.  I locate the Aperture Library under Pictures in my Home folder; I hold down the Command and Option keys and double click on the Aperture Library file.  Aperture just opens normally; the Aperture Library First Aid dialog does NOT appear.  I've tried this repeatedly. I even shut down my Mac, rebooted, and tried again.  Same result.
What am I missing?  Can anybody help?

 Bobolink's gear list:Bobolink's gear list
Pentax K-01 Pentax K-5 IIs Pentax K-3
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow