Weird CF Card Corruption

Started Dec 4, 2012 | Discussions thread
Flat view
RPK Senior Member • Posts: 1,104
Weird CF Card Corruption

I have three Lexar 300x UDMA compact flash cards. All three have been in my posession for two+ years. None have ever failed, not once.

Over the weekend, I shot approximately 450 photos with my Nikon D3.

When I tried to copy the CF to computer, I noticed two blocks of files missing, approximately 80 or so in a series.

During the copy, Windows Explorer found "duplicates" and asked if I wanted to overwrite or save a copy. I chose to save a copy. On the comptuter the file names were xxxx(2). As you may know, the same filename cannot reside in the same path; file names must be unique.

Looking at the card however, there were no "duplicates". There were however numerous folders with random ASCII characters, not were accessible however.

I ran Microsoft CheckDisc on the card and it found all sorts of errors such as "invalid time stamp", "zero file size", "file allocation is not valid", "first allocation unit is not valid" and so on.

CheckDisk recovered my missing files, all were intact and ready to go.

I doubt my D3 corrupted the card and I wonder if the card reader could be culprit.

Has anyone heard of a card reader corrupting files?

Is there any CF testing software to check performance and controller? There are a few for hard drives but I don't see anything for memory cards.

Any suggestions on what may have caused the card corruption?

-- hide signature --

Visit my Boxing & MMA Gallery:

Nikon D3
If you believe there are incorrect tags, please send us this post using our feedback form.
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow