What's wrong?!

Started Nov 27, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
Zoso777
Zoso777 Regular Member • Posts: 247
What's wrong?!

Dear friends,

I design and shoot some jewels with my Nikon D7000. In this set, I've tried to add some smoke to the pendant and for that I used a SB-700 off camera with a blocker attached to the flash in order to prevent light reaching the black background . I used to shoot smoke some time ago and got nice results but that's not the case with these photos. Camera was in manual mode set to f16 1/320 ISO 100. The room was totally dark, so light came out of the SB700 only.

Can anyone help me telling why there are so many light spots, smudges,flare ? I'm sure it's not the sensor nor dirty lens…i'm very upset with these terrible results.

Below are my camera and flash setup:

==== (black background)

@ (subject) < (flash)

|| < (camera)

Photo with no crop…as you can see there are tons of light spots (?) that look like smudge and not a dark background.



Another photo cropped but with that boring spots yet...

Photo with some fixes in LR to hide the spots and make the background darker…

Thanking you so much in advance.

-- hide signature --

Are you nervous? Go photographing!
http://www.flickr.com/photos/hegner/
dragaomistico.tanlup.com

 Zoso777's gear list:Zoso777's gear list
Nikon D750 Nikon AF-S Nikkor 50mm f/1.8G Nikon AF-S Nikkor 24-85mm F3.5-4.5G ED VR Nikon AF-S Nikkor 70-200mm f/4G ED VR +1 more
Nikon D7000
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow