LR4? Malware? Old age?

Started Sep 12, 2012 | Discussions thread
mblg Regular Member • Posts: 392
An unexpected reason (probably)

Jeanadriane wrote:

Jeanadriane wrote:

Hi All,

Knock-knock, can I come in? I'm new to this forum, but since 2009 a member of the µ4/3 forum. And now I hope to find some help with my MacBookPro 15"...

I bought it in March 2010 but somehow had a feeling / impression it was produced in July 2009. Between mid Nov 2011 and mid May 2012 it wasn't used as I was traveling and had left it home. Processor is a 2.66 Ghz Intel Core 2 Duo, RAM has recently been upgraded from 4 to 8 GB 1067 Mhz DDR3. OS X 10.6.8. Harddisk is 500GB with 282GB free space.

In spite of the extra RAM it'sslooooow. With LR4 it often borders on being unuseable. With internet it's a lot slower than say a year ago. In other respects it's not as fast as it used to be, but not too troublesome either.

I'm used to doing clean reinstalls on a half year basis, to keep the machine up to speed. Recently I've been doing one again, but it as opposed to previous years, this time it didn't bring back the old speed and soon the machine was as slow as before the reinstall. I regularly check for malware with ClamXav. And recently tried to solve my problems with DiskWarrior. Before the last reinstall I regularly used Onyx.

Today I ran ClamXav again, and that showed no infected files, but some 130 errors. Time to repair permissions, I guessed, and gave DiskWarrior a next try. But the program gets stuck in "searching for disks", over and again, and the only way to break the spell is to force a shutdown of the MacBook by pressing the on/off key for a couple of seconds.

So I went back to the Mac's own Disk Utility to check for permissions to repair. The first analysis brought up a list of some 15-20 permissions that needed repair. I clicked the repair button. After the repair was completed I checked again, and lo 'n behold, in spite of the repair the list with permissions gone wrong was even much longer now! I repeated the procedures twice, and then gave up, deciding to turn to you guys & gals for help.

What worried me, is the fact that all damaged permissions are related to Java, that there is something wrong with the user, and that three found problems have to do with remote management. Now, maybe I'm reading much more into this then I need to. But still.

Does anybody here have a notion what could be the problem with my MacBook? Is it just LR4 that requires too much for this machine? Should I reckon with malware? Or is a MacBookPro simply outdated and useless at the tender age of 2 1/2 or 3 years?

Here I add two pics I took from the screen in Disk Utility.

Some translations:

Bevoegdheden verschillen op ... moeten zijn... zijn nu .... =
Permissions differ at ... should be... are now...

Gebruikers verschillen op... Moet zijn 0, gebruiker is 95 =
Users differ at... should be 0, user is 95

Waarschuwing: SUID-bestand... is gewijzigd en wordt niet hersteld =
Warning: SUID-file... has been changed and will not be repaired

Thank you VERY much for taking a look here and giving my question a thought!!!



Hi All,

Time for an update, after all your kind and much appreciated advice...

First some extra info: I load my previews at 1:1 and I always remove my pics from LR after I finish. Only very rarely do I have more than 100 images in LR. I never run other applications when LR is running. I do not use an external monitor.

I was very happy with your reactions and followed a lot of advice and did a lot of internet reading. I checked to see if virtual memory is enabled, and yes, it is. I opened the machine and vacumed the fans, but they were surprisingly clean already. I've installed Mountain Lion (and sacrificed Office 2004 as well as my i1 Display 2), got rid of Java and ClamXav, but installed Sophos (no malware found), installed Little Snitch too (all outgoing connections appeared to be totally OK and when in doubt I google for my education, only to find the connection asked for by LS was OK too), looked at the link about resetting the SMC and found out I already had done that, adapted my LR routines and now wait with NR and sharpening till the very end of the process (but still have to apply clarity in the beginning, as that really influences the look of the image, and often also use clarity in local adjustments).

I also made friends with my activity monitor and kept checking it. What I found: nothing keeps the CPU busy for more than a few percents more than a few seconds. Even LR, when it already was slowing down big time, never took up more than some 3,8%.

The only strange thing I found, had to do with available, inactive and active memory, and paging. Usually I have a LOT of inactive system memory, some 3.5 to 5.3 Gb (out of 8 Gb), and the machine does not use it but starts paging instead. For instance, at this very moment I have *not* been using LR for some 10 hrs, but I was on the internet and watched the video about the Nat Geo guy and the huge seal. The LR library is completely empty as I finished a project and removed all images. I have Firefox open for DPR, as well as the texteditor to write the text for this post, and the activity monitor. Firefox and the activity monitor are the only apps that take up more than 0.5%, and not even that all of the time. Firefox also goes down to 0.1% a lot of time. Available memory is 299 Mb, active is 1.51 Gb, inactive is 5.28 Gb, page-ins is 2,42 Gb and page-outs is 1.7 Mb. So it seems inactive memory is not accessed easily and instead the machine reverts to paging. I wonder if that tells me something...

Oh, and the results of all this? The machine is worse than ever, it keeps getting slower and slower, day after day. The spinning beach ball is doing overtime. My internet gets slower and slower too. LR is pure hell.

If I weren't leaving by mid December for more than six months in a remote place, I'd bite a next bullit and upgrade, albeit gruntingly and swearingly. But with this travel ahead, and realizing what a short life span these computers have, I don't wanna loose half a year by having the brand new thing waiting for me at home and getting outdated while I'm out in the other hemisphere taking pictures.

If anyone of you has a next brilliant idea, I'd be most & utterly grateful!!!
And otherwise: thanks you all for the kind help and inspiration you gave me!



Hi, Jeannette,

I tried to read carefully your long email. Very informative.

Look, the problem with latest PP software (and I include here LR and PS) is that they do not rely anymore only on processor and RAM. Maybe you are aware that modern software makes hard use of GPU (graphics card) processing power. Many routines that require intensive processing algorithms have been moved in GPU code because this is better adapted to parallel programming. Well, this is simplified a lot, but I hope you got the idea.

Thus, an older computer with an older GPU (or even no separate GPU at all) might have problems with updated software. What usually happens is that programmers (in the source code) check to see what hardware you have on GPU side (the "NVidia" or "ATI" stuff). If it is supported, then those routines are passed to the GPU. If not, everything (or almost everything) is done in the CPU (the "Intel" stuff). Thus, the computer seems to run slower with modern PP software.

I won't dive into details, but just Google "OpenCL" or "CUDA" (for example) if you want to read and understand more.

It is important to see how does your computer behave when you do not use PP or LR. For example: archiving, de-archiving; copying files, doing some other regular activities. I have a 2010 (I think) MBP and had no issues with it. But, true, has dual GPU: An Intel 3000 and a Radeon 6490M.

More: Mountain Lion is much faster than Lion. Apple got rid of all (they say so and it seems true) legacy 32 bit Carbon framework (Google "Apple Carbon"), the system is very modern and updated. It should be more responsive.

Check first what GPU you have.

Let me know if I can be of any support.

-- hide signature --

Warmest regards,

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow