Aperture 3: Every date is January

Started Oct 10, 2012 | Discussions thread
OP prime Senior Member • Posts: 1,860
Re: Sounds like something is 'stuck'

noirdesir wrote:

"It is hard to predict the prior knowledge when explaining something. Probably I just explained something to you  in the previous paragraph that you already knew. Explaining too much can appear as lecturing (and can cost a lot of time). But just ask back, I am happy to explain in more detail if something is unclear."

Thank you for your patience and willingness to make sure that we are on the same page.  I appreciate your efforts.  I wish that dpreview's software ​experts were a little more ​accomplished​ at their craft so that I could reply in a more, erm, "formatted" way.

"One possibility is that you might have tried to do all three things at the same time (alt, cmd, and double-clicking), try pressing and holding down alt and cmd first and then double-click the library. If that does not work, you might yet another unsolved mystery (but as I said just above, the problem does not seem to be in your library)."

The problem seems to be in the Help text within Aperture.  As explained below, holding down Option and Command while clocking on the application icon (instead of on the Library as Aperture Help directed) eventually did the trick.

Since my last post on dpreview, I have finally been able to get into the Repair dialogue (the Help screen within Aperture was wrong) and have:

1. Repaired the permissions, AND

2. Repaired the database, AND

3. Rebuilt the database.

The problem remained.

I went to: http://support.apple.com/kb/ht3805 and followed the instructions to delete the user preference.

The problem remained.

As suggested there, I moved the user created presets, keyword lists, and so on...

The problem remained.

So I tried to reinstall Aperture. I originally had installed it from DVD, and I am still on Snow Lion, so I followed the instructions to:

1. Open the Applications folder.

2. Drag the Aperture application to the Trash.

3. Open the Utilities folder within the Applications folder.

4. Open the Terminal application.

5. On the command line, type the below command (which is case-sensitive) and then press Return:

sudo pkgutil --forget com.apple.pkg.Aperture

6. When prompted, enter your user password and press Return.

BUT THEN, I received the message:

Unknown error Error Domain=NSCocoaRttorDomain Code=4 UserInfo=0x10016d7f0 ""com.   apple.pkg.Aperture.bom" couldn't be removed." Forgot package '.com.apple.pkg.Aperture' on '/'.

Note the double double quotation marks "" in the first line: in the message, the two characters are different double quotation marks, not the same.

And in the second line, see the Aperture.bom; that is not a typo: bom, not com.

But, anyway, I proceeded to step 7:

7. Insert your Aperture disc and install Aperture. But, after whirring for several seconds, the MacBookPro rejected the installation disk. Repeated attempts to insert it were not successful in getting the MBP to read the inserted disk.

IOW, failure.

So I decided to try to go back. I went to the Trash folder and dragged the Aperture application back to the Applications folder. Of course that did not work. When I tried to open Aperture, I got an error message that Aperture is in the Trash folder (which it was not, not any longer).

Fortunately, I had a September 29 Time Machine back-up, so all was not lost.  After a restore, I now am roughly back where I was when I started this thread:  I have all my Aperture images, but every one of them has the year and day of the month correct, but the month for every image, whenever taken, is shown in Aperture as January.

... there is more on the OS level but start with the above first.  Before I send you off on a whole set of OS level 'repairs', (and after you have done the OS permissions repair) does this inability to launch applications from the new user account extend to applications other than Aperture?

Feel free to suggest new excursions and explorations.  I am fearless to try strategies that might free me from Aperture January.   Thank you for your patience so far.

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow