Where can I find the X10 FPUPDATE.DAT file for version 1.03?

Started Oct 10, 2012 | Discussions thread
Billx08 Forum Pro • Posts: 11,373
Re: You can find the X10 FPUPDATE.DAT file for version 1.03 here

wonko 67 wrote:

Billx08 wrote:

As noted above, "I tested it and it works." I also compared it with a previous v1.03 firmware and the files were exactly the same size, to the byte, but the md5 checksums were different. So I looked at them with a hex editor and saw that they were substantially the same, with very slight differences so I installed it. As I wrote, "it works", meaning that it did indeed install itself as version 1.03. I took a couple of photos but did no other testing and then reinstalled version 2.0. While unlikely, it's still possible that this "v1.03" firmware is a patched version to make v2.0 show "v1.3", so all anyone has to do is check the functionality of the RAW button to see if it's a v2.0 in sheep's clothing. If it is, the search continues, and the unpatched v2.0 can be reinstalled, or not, as desired.

If you found that I was a little rude, I apologize: it was not my intention.

No, I didn't think that you were rude, I was just explaining what I had done.

As to the file size, my guess is that ​all​ firmware versions have ​exactly the same size, so that when "upgrading" the new one simply replaces the old one, bit by bit. If it is like that, then it is not much of a surprise that it is possible to "downgrade" to an older version.

That's probably true for Fuji's firmware, but some other firmware upgrades I've encountered are variable in size and simply overwrite what was previously stored in the EEPROM. Fuji probably fills out the unused portion of the firmware to fit the available space, leaving enough slack to allow future firmware versions to add routines. Part of the reason that I mentioned the file size though was because the first time I tried downloading the v1.03 firmware (back on August 1, I see) the X10 gave me an error message. So I downloaded it again and this time I got a good copy that was about 500 bytes smaller than the corrupted version. I reported this in some previous DPR thread.

I tested the file you linked agains the official 2.0 even with (all flavours of) sha: the digests allways match.

If they are different files, it means that fuji technicians succeeded (either by chance or intentionally) in producing two different files with the same hash for all these functions: it is something that I (very very very) hardly can believe, so I am quite confident they are just the same file.

BTW: you downgraded from 2.0 to a supposed 1.03 and you didn't check if the raw button was back there?

That's what I wrote, as a precaution (no clairvoyance) to anyone else downgrading from 2.0 to 1.03. I just downloaded the supposed v1.03 firmware from that French website and it has the same MD5 checksum as the v2.0 firmware. So I tried to use it anyway to see what would happen with the X10 currently using v2.0. It recognized it as a 2.0 firmware upgrade. So it appears that you're correct, because it's much more (stressing much, much, much more) likely that I accidentally copied my existing v1.03 firmware to the SD card than that the two different files had the same hash value. Thanks for spotting the error but I'm surprised that the link that I provided was actually to a 2.0 version of the firmware. Every other web page I've seen that says that it has a link to the 1.03 firmware provides a link to Fuji's support website where the software is clearly identified as v2.0. This French website hosted their own download, but didn't update the web page to show that it was for the v2.0 firmware.

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow