Unable to update OM-D firmware

Started Oct 4, 2012 | Questions thread
Shop cameras & lenses ▾
Flat view
adbit New Member • Posts: 8
Unable to update OM-D firmware

I am on an iMac 10.7.5

installed the Olympus updater  (installed and re-installed)

When I connected my OM-D (1.1) with a 9-18 attached, firmware update requirements was identified for the camera as well as for the lens. 
I started to update the lens, it worked as expected (including message on the camera display)

When I then tried to upgrade the camera (from 1.1 to 1.3 in the first step) I come as far as to the license agreement dialogue, when I press "accept" the "don't remove or turn off the camera" window is displayed on the computer, nothing happens though, nothing is displayed on the camera monitor and when I look at the Olympus Updater process from the Mac OS activity moitor, it seems to idle.

After about 10 minutes I unplug the camera, with no effect upon the updater, has to Force quit the updater software....

Original Camera firmware was not affected

Have tried this several times, with "Auto" as well as "Storage" selected from the camera USB menu

Am I missing something?

This question has not been answered yet.
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow